An introduction to the Microcal Origin scientific charting package.

AUTHOR
Information Systems Services
University of Leeds

DATE
December 1999

EDITION
1
Contents

Introduction 1
   Aim of this Document 1
   What Is Origin? 1

Task 1 Running Microcal Origin 2
Task 2 Creating a Simple Graph 4
Task 3 Editing Graphic Elements 8
Task 4 Obtaining Printed Output 12
Task 5 Importing Data Files 13
Task 6 Multiple Graphs on the Same Page 14
Task 7 Curve Fitting : Pre-Defined 15
Task 8 Curve Fitting : User-Defined 18
Task 9 Creating a 3D Graph 20
Task 10 Creating a Surface Plot 23
Task 11 Quitting Origin 25

Further Information 26
   On-line Help 26
   Documentation 26

Appendix 1 Types of Graph Available 27
   2D Graphs 27
   3D Graphs 28

Appendix 2 Origin Examples 30

Format Conventions
In this document the following format conventions are used:

<table>
<thead>
<tr>
<th>Commands that you must type in are shown in bold Courier font.</th>
<th>WIN31</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input which must be replaced by your details is given in italics</td>
<td>LOGIN server/username</td>
</tr>
<tr>
<td>Menu items are given in a Bold, Arial font.</td>
<td>Windows Applications</td>
</tr>
<tr>
<td>Keys that you press are enclosed in angle brackets.</td>
<td>&lt;Enter&gt;</td>
</tr>
</tbody>
</table>

Feedback
If you notice any mistakes in this document please contact the Information Officer. Email should be sent to the address a.clough@leeds.ac.uk

Copyright
This document is copyright University of Leeds. Permission to use material in this document should be obtained from the Information Officer (email should be sent to the address info-officer@leeds.ac.uk)

Print Record
This document was printed on 14-Mar-00.
Introduction

Aim of this Document

This document describes the Microcal Origin + 3D module program. The document is intended for new users. It describes the basic features available in Origin and gives advice on printing and including data from external sources. It also includes a simple exercise in the use of Origin.

What Is Origin?

Origin is a technical graphics and data analysis software. It is fast, powerful, easy to use and ideal for anyone who needs advanced graph plotting, data handling and analysis. With its drawing tools, Origin provides flexibility in creating complex graph and publication quality output. Origin provides a graphing environment where you can enter your data, or import data files from other applications, to create professional looking graphs, and output them on a variety of devices.

Origin 6 is available on the Novell network under Windows NT. Users with standalone PCs can purchase the software from the ISS. The ISS can also sell networked versions of the software for installation on departmentally managed PC networks.
Task 1  Running Microcal Origin

Objective  To run Microcal Origin.

Instructions  You will need to run Windows NT. If you are using a PC on a computer network you will first need to login to the network.

Comments  You will need to have access to a PC which runs Windows NT in order to carry out this activity.

Activity 1.1  Open Windows NT and click on Start > Programs > Graphics > Origin 6 (see Figure 1).

(Your desktop may look slightly different if you are not logged on to the Information Systems Services network. If this is the case, you may need to ask your departmental Computer Officer if and where Origin 6 has been installed.)

Note  Origin 6 can also be run from ZENworks (see Figure 2). For information on how to get ZENworks - Open a web browser such as Netscape and go to the following URL: http://www.leeds.ac.uk/iss/NT/zenworks.html

Figure 1. Finding Origin 6 on the Windows NT desktop  Figure 2. Finding Origin 6 in ZENworks
The screen shown in Figure 3 is displayed.

Figure 3. The Origin screen

**Activity 1.2** Ensure that all menu options will be available for the session by checking Full Menus from the Format, Menu menu, as shown in Figure 4. When it is selected, it has a bullet against it, as shown.

Figure 4. Menu selection
Task 2 Creating a Simple Graph

Objective
Creating a simple graph.

Instructions
Enter data into the worksheet and create a graph.

Comments
Type in the data as shown.

Activity 2.1
The default number of columns is two. In this example we require three columns of data. To add another column to the worksheet, click on the Column menu and choose the Add New Columns... option or click on the icon from the toolbar. Click <OK> to add the default number of columns, 1. An extra column named \( C(Y) \) is added.

Activity 2.2
Enter some data into the worksheet as shown in Figure 5. Change the name of column C by clicking on the column \( C(Y) \) heading. Select the Column menu and then the Set as Y Error option. Column C will now show the heading \( C(yErr) \), as shown in Figure 5.

Activity 2.3
Un-highlight column C. Click on the Plot menu and choose the Line+Symbol graph. You are then given the opportunity to select the values you want to display, as shown in Figure 6, the Select Columns for Plotting dialog box. Highlight \( A(X) \) in the left hand column and then click on the button. This tells Origin to put data from column A along the X Axis.

Next, highlight \( B(Y) \) in the left hand column and then click on the button. This tells Origin to put data from column B along the Y Axis. Click on the <OK> button when you have finished.
Activity 2.4  A new plot window appears showing Column B plotted against Column A onto a default set of axes. A legend automatically appears at the upper right corner of the window, showing the data set name, and plot type as shown in Figure 7.

The data set name in this example is B as that is the current column heading. This can be changed to something more descriptive in two ways:

- change the legend entry in the graph window, or
- change the column heading in the worksheet.

Activity 2.5  To change the legend entry in the graph window, double-click on the item in the legend (in this case the letter B). The following dialog box appears:

The characters in the middle box indicate what will be displayed in the legend. In this example, \texttt{L(1)} means that the linestyle and colour of line number 1 will be displayed and \texttt{%(1)} means that the column heading for the first plotted dataset will be displayed. To change the text, delete \texttt{%(1)} and enter the required text as shown in Figure 9. The format of the legend text is shown in the bottom section of the Text Control dialog box (also shown in Figure 9).
Activity 2.6  To change the legend by renaming the required column, double-click on the required column in the worksheet. The following dialog box appears:

Enter the new name into the Column Label and press <OK>. Choose whether to display the Column Label in the Data window. The legend in the graph will not be updated automatically – to update it, click on the graph window and then click on Graph, New Legend. The graph legend will be updated.

Activity 2.7  Plotting error bars is very simple. You could do it when you create the Line+Symbol plot by selecting Column C and entering it using the button, as shown in Figure 6. Alternatively, as in this example, you may add error bars once you have created the Line+Symbol plot.

Error bars can be added to plots in two different ways: to add error bars that you wish to be computed as a percentage or a standard deviation of the data - select the Add Error Bars... option from the Graph menu.
For this example, we will add error bars from a dataset – double click on the layer icon in the top left hand corner of the plot window. The Layer dialog box (Figure 11) appears. Select the dataset that you want to use from the Available Data – in this case data1_c – and press OK to add it to the layer. As the column has already been defined as error bars, that is what will be plotted. Press OK.

Figure 11. The Layer dialog box

The plot is now redrawn with error bars, as shown in Figure 12 below:

Figure 12. A Line+Symbol plot with error bars

To zoom in and out of a graph, use the zoom icons on the main toolbar. Choose View, Whole Page to return the graph to its original size and position.
Task 3  Editing Graphic Elements

Objective  To edit the graphic elements of a plot.

Instructions  You will edit the graph style and colours and use the Tools toolbar to add a text label.

Comments  Experiment by editing the other graphic elements as well.

Activity 3.1  Editing graphs in Origin is straightforward. Each graph is composed of a variety of graphic elements. To change any element, you must position the mouse on that element and double-click the left hand mouse button. Figure 13 shows most of the graphic elements that can be edited by double-clicking.

Activity 3.2  Double click on one of the datapoints on the graph: the dialog box that appears (Figure 14) enables you to change the graph type, the colours, line styles, shapes of data points etc. Click on the Line tab and change the type of line to spline and make it a dotted violet line with no gap between the line and the data points. Press <OK>. This will produce a curve which passes through the data points.
Most elements on the graph are grouped with other similar elements - for example if you double click on one of the data points and change its colour, all the other data points for that dataset will also change. If you want to override this grouping, hold down the <CTRL> key when you double click over the point and any changes that you then make will affect only the selected point.

**Activity 3.3**

Hold down the <CTRL> key and double click over a data point, change the colour to red. The selected point should be the only one that changes. This is a good way to highlight individual points.

**Activity 3.4**

Alternatively, elements can also have their attributes selected automatically using column values. Add a fourth column to the worksheet as in activity 2.1 and enter the following values into it: 4,2,4,2,4. Highlight the first 3 columns and select Plot > Line and Symbol – this is a quicker way to produce a plot than activity 2.3. Double click on one of the data points on the new graph. In the Plot Details dialog box choose the Symbol tab. From the Symbol Color list choose Indexing, Col(D). Check the Show Construction box and from the Shape drop down menu choose Col(D). Press <OK>. The resulting plot should show some points as blue triangles and others as red circles.

**Activity 3.5**

To add text to a graph, for example a title, it is necessary to use the tools toolbar. If the Tools toolbar is not available it may have been switched off. To open this toolbar, click on the View, Toolbars menu option. From the toolbars dialog box select Tools. It should now be displayed.

The first six tools from the left are used mainly for working with data in plot windows. The next six are used to add labels to a graph or to a worksheet. A detailed description of these tools is available in the Origin User’s Manual.

To add a title to the first plot, for example, click on the Text tool and position the cursor as desired in the plot window. Click again and the Text Control dialog box will appear, as shown in Figure 16. Type the desired text where it highlights 'enter text here' and click on the <OK> button. The title will now appear on the plot.
Special characters such as ° and Greek characters can be inserted by typing ****, where **** is the ASCII code for the required symbol. Note - the ASCII code must be typed on the number pad of the keyboard while holding down the <Alt> key. e.g. 0174 gives the symbol ®

**Activity 3.6** Items in columns can also be used for labels:

Highlight Column A, select **Column > Set as Label**. Enter labels into Column A, overwriting the numbers e.g. **sample 1, sample 2, sample 3, sample 4, sample 5**.

**Note** - Column A no longer represents the x data; if there is no x column selected then Origin will use the row numbers by default.

In the Graph window, double click on one of the numbers under the x axis. In the dialog box, choose the **Tick Labels** tab and select **Text from dataset** as the tick label Type and then **Data1_A** as the Dataset. Click <OK> and the graph should now look like:

![Figure 17. The graph with the x-axis labelled](image)

To add more data to a graph, you can simply type in more data into columns that are already plotted - the graph should automatically redraw.

**Activity 3.7** To add complete new datasets to a graph, add a new column to the worksheet as before, add the new data into Column E. Double click on the layer icon in the top left hand corner of the graph window. The box shown in Figure 18 appears.
Select `data1_e` and press the \( \rightarrow \) button to add the dataset to the Layer Contents box. Press <OK>. The new data should now appear on the graph alongside the first dataset, as in Figure 19, and can be edited in the same way. Datasets can also be deleted from graphs by using the \( \leftarrow \) button.

![Figure 18. Adding another dataset](image)

To update the legend, select Graph > New Legend, or press the New Legend icon on the main toolbar, and then alter the legend text as shown previously.

![Figure 19. The graph showing the new dataset](image)
Task 4 Obtaining Printed Output

Objective  To obtain a printed copy of your graph.

Instructions  You will use the Print Setup dialog box to attach to a printer.

Comments  Make sure that you attach to the correct printer.

Activity 4.1  Before you print your graph you must make sure that you are connected to the correct printer. (You will normally find that each printer is labelled with its name.)

From within Origin, select File > Print. Click on the drop-down menu by Name and select a printer.

Activity 4.2  You can set your paper size, orientation and other settings using the Document Properties dialog box which can be accessed by selecting the Properties button. Figure 20 shows the Print dialog box.

Activity 4.3  Create and edit your graphs as previously described. Select File > Print to print a single graph.

Note  You may want to print several graphs on the same page. To do this select File > New > Layout. A new window should appear with a blank page on it. Use the Layout > Add Graph and Add Worksheet options to position graphs and tables on the blank page for printing. Size the graphs and worksheets on the layout page and align using the Object Edit tools which can be accessed by selecting View > Toolbars and selecting Object Edit. The Object Edit palette shown in Figure 21 provides tools which allow for easy arrangement of objects. The action of each button is explained in the Origin User's Manual.
Task 5 Importing Data Files

Objectives To import data from another format.

Instructions You will import an ASCII file.

Comments You need to be using a networked PC to use example data files.

In Origin, it is possible to import data from other formats. The import formats include ASCII, Lotus, Excel, dBase, Symphony, sigmaplot, sound wave and Dif. The export formats include ASCII files, WMF, EPS and BMP. For this example we will import an ASCII file.

Activity 5.1 Open a new worksheet by selecting File > New > Worksheet. Click on the File menu and then choose the Import > Single ASCII option. The File Open dialog box should appear listing files with a .dat extension. Figure 22 shows the File Open dialog box.

Figure 22. File Open dialog box

If no files are listed make sure you are in the correct directory:

L:\win32apps\Origin41\Samples

Click on the test3.dat file name and then click Open. The ASCII file test3 is now open in Origin. You might also use cut/copy/paste or DDE (Dynamic Data Exchange) with Origin. DDE is a Windows feature that enables communication between applications that run under windows. DDE allows a graph in Origin to be dynamically linked to data in another windows application that supports DDE, such as Excel. When you alter the data in Excel, the graph in Origin is automatically updated to reflect the changes. You can also use DDE to paste Origin graphs into a word processing package such as Word for Windows. The Paste Link command in the Edit menu is used to create DDE links in Origin.
Task 6  Multiple Graphs on the Same Page

Objectives  To plot two different graphs on the same page.

Instructions  You will import an additional data file into the document.

Comments  You need to be using a networked PC to use example data files.

Activity 6.1  You should already have test3.dat imported into Origin from the previous example; if not, do it now.

Activity 6.2  Highlight the Column Cp by clicking on the Cp(Y) heading. Open the Plot menu and choose the Line option. The first data set and graph has now been produced.

Activity 6.3  Now select the New, Worksheet option from the File menu and import the ASCII data file TEST2.DAT as previously. Highlight Column B by clicking on the B(Y) heading and choose the Line option from the Plot menu. Graph 2 will now open containing a second graph.

Activity 6.4  Make sure that Graph 1 and Graph 2 are the only windows open. Click on the Graph 1 window to make it active and choose the Merge All Graph Windows option from the Edit menu. A dialog plot will appear asking if you want to keep the old plots – click on YES. You then get the layering and spacing options, choose the default settings for now by clicking <OK>. The two graphs will appear Graph 2 below Graph 1.

Click on the Edit menu and choose the Add & Arrange Layers... option. Click <OK> and then alter the vertical gap from 5 to 10. Click <OK>. This will add a little more vertical space between the plots. The following plot should now appear:

![Figure 23. Two graphs on the same page](image-url)
Task 7 Curve Fitting: Pre-Defined

**Objective**  To introduce the concepts of curve fitting.

**Instructions**  You will use as an example a pre-defined function.

**Comment**  You need to be using a networked PC to use example data files.

When you are in a Graph window, Origin’s linear and polynomial fit menu commands are located in the **Analysis** menu. Parameter initialization and fitting is carried out automatically when fitting from the menu. A fit curve is displayed in the graph window while the fitting parameters and statistical results are recorded in the Script window.

The **Analysis** menu contains the most frequently used models which include:

- Linear Regression
- Polynomial Regression
- Exponential Decay (first order, Second order and Third order)
- Exponential Growth
- Gaussian (single & Multiple)
- Lorentzian (single & Multiple)
- Sigmoidal
- Multiple Peaks
- Non-linear curve fit (one of the above or User defined one)

Users can add their own fitting function or have more control over fitting parameters by using the **Nonlinear Curve Fit** option from the **Analysis** menu.

**Activity 7.1**  Consider a curve fitting session using one of the pre-defined functions. To try this example you should open the file `fitexmpl1.opj` which is available under `L:\win32apps\Origin41\Samples`. Figure 24 shows the plot which will be used for the example.

![Figure 24. Scatter graph](image)
From the **Analysis** menu choose the **Fit Exponential Decay - First Order** option. Origin will do the necessary initialization and fit the data. The result of this operation is shown in Figure 25:

![Figure 25. "First order - exponential decay" curve fitting](image)

A Script Window also appears, giving details of the fitting parameters.

**Activity 7.2**

In the above case the X offset is assumed zero by the auto initialization. To allow an X offset you should choose the **Non-Linear Curve Fit** option from the **Analysis** menu. A new set of menus is displayed and the following dialog box appears:

- Click **Select Function** and choose **ExpDecay1** from the functions list.
- Click **Start Fitting**, followed by **Yes**.
- Make sure the **Vary?** check box for \( x_0 \) is checked
- Click **1 iter** button on the menu bar and then click **Done** on the menu bar

This will update the plot and the contents of the Script Window with the new fitting parameters.

Figure 26 shows the basic NLCF Mode. The advanced NLCF mode can be accessed by clicking on the **More** button from the basic mode (see Figure 27).
While both modes enable you to fit your data, they differ substantially in the options they provide as well as in the degree of complexity they entail.

The basic mode is simpler and is used for selecting a function, selecting datasets for fitting, performing an iterative fitting procedure and displaying the results on the graph.

The advanced mode includes the above and allows the user to define a script to initialize parameters, impose linear constraints, define your own fitting function, specify a weighting method and termination criteria, display confidence and prediction bands, residue plot, parameter worksheet, and the variance-covariance matrix. It also allows the user to fit multiple datasets with a choice of shared parameters and change parameter names.

Figure 27. Advanced NLCF Mode
Task 8  Curve Fitting: User-Defined

Objectives  Curve fitting using a User-defined function.

Instructions  You will use an example of a User-defined function.

Comments  You need to be using a networked PC to use example data files.

Activity 8.1  Consider a curve fitting session using a user-defined function. To try this example you should open the file fitexmp2.opj which is available under L:\win32apps\Origin41\Samples.

To enter a new fitting function, from the Analysis menu choose the Non-linear curve Fit option. The following dialog box will be displayed:

Click on the New… button. From the Edit Function Menu enter 3 in the Number of Param. box. Next enter the following into the Definition box at the bottom:

\[ y = y_0 + A e^{-x^2/P_3} \]

and click the Save and then the Accept button.

Activity 8.2  To start the fitting session from the menu in Fig. 28, click on the Start Fitting button. You will be prompted for a choice of fitting the curve for the active data set or any other. Choose the active dataset. The fitting session menu appears and you need to set the starting values for P1, P2, P3 in the boxes adjacent to the parameters e.g. try P1=7, P2=2, P3=2.

If you want to fix the value of any of the parameters you must click on the box next to the value box that says Vary? as shown in Figure 30. If the Vary? boxes are checked it allows the parameters’ values to change during the iterations.

Click in the 1 Iter. or 10 Iter. box to do the curve fit. Repeat the iterations until you get a satisfactory fit. Once you are happy with the curve, click the Done button to terminate the fitting session.
Figure 31 shows the result of fitting the function to the plot.

Note

The option More... during the Fitting session provides the user with more sophisticated options to control the fitting parameters. The NLCF Controls menu (Advanced mode) is an easy way to get fitting results and perform constraint control.
Task 9 Creating a 3D Graph

Objectives To create a 3D graph.

Instructions Enter data into a worksheet and produce a 3D plot.

Comments Enter the data as shown.

Remember to set menus on Full by selecting FORMAT then select Menu then Full Menus option.

Activity 9.1 Open an Origin worksheet by clicking on the File menu and choosing the New option, and the Worksheet option. This will open a worksheet with two columns – you will need to add a third column to the worksheet as done in Task 2 previously.

Activity 9.2 Enter the following data into the worksheet. You will need to change the name of the heading to C (Z).

To do this, click on the column heading and then click on the Column option. Choose the Set as Z option. The worksheet should now resemble Figure 32:

Activity 9.3 To draw a 3D scatter graph, click on the C (Z) heading in column 3 of the worksheet. Next click on the Plot > 3D XYZ menu and choose the 3D Scatter option. The data will be plotted into a new plot window and the 3D toolbar will also appear.
Activity 9.4  The Plot Details dialog box allows you to choose and change various parameters of a 3D scatter plot.

To open the Plot Details dialog box you can either double click on a plotted data point or click on the Format menu and choose the Plot option. The following dialog box appears:

![Figure 34. 3D Scatter Options dialog box](image)

As you can see, the 3D plot is not particularly easy to interpret at the moment. The following formatting procedures should be carried out:

1. To join the points with straight lines (a Trajectory Plot) you can either click on the Connect Symbols section in the Line tab, or plot another graph, highlighting column c(Z) as before and then choosing the Trajectory option instead of 3D Scatter.

2. To add drop lines choose Drop Lines tab and check parallel to Z axis.

3. To remove the grid lines from all three axes click on Layer 1 in the left hand side of the dialog box and choose the Display tab. In the Show Elements section uncheck the X Axes, Y Axes, and Z Axes options. Then click <OK>. The plot should now resemble that in Figure 35.

4. To make the points bigger and to number them you should re-open the Plot Details dialog box as before. Select Original from the left hand side of the dialog box. Click on the Symbols tab. Choose Show Construction, Row Number Numerics, check the Outline box and choose Size 24 from the drop down list. Then click <OK>.
5. To trace a line onto the bottom of the graph, open the **Plot Details** dialog box again and turn off the **Parallel to Z axis** in the **Drop Lines** section by clicking in the adjacent check box. Then click the **XY Projection** checkbox in the left hand box of the Plot Details dialog box, so a tick shows in the checkbox. Finally click on the check box next to **Connect Symbols** in the **Line** tab. The graph should now resemble Figure 36 below:

![Figure 36. Formatted 3D plot](image)

The **3D** tool bar has several buttons that can be used to rotate and change the perspective of the 3D graph. The top six buttons in the 3D palette rotate the 3D plot by the rotation increment when clicked. The next two change the perspective angle. The next two are a reset rotation and fit graph to layer frame buttons. More details are available in the 3D/Contour Manual. If the 3D Toolbar is not displayed, open it by selecting **View > Toolbars > 3D Rotation**.
Task 10 Creating a Surface Plot

Objective To create a Surface Plot from 3D data stored in a matrix window.

Instructions Create a Matrix from Worksheet data and plot as a 3D surface.

Comments Use the matrix details given.

Remember to set menus on Full by selecting FORMAT then select Menu then Full Menus option.

Surface plots can only be plotted from matrix windows; data in a matrix can either be created from formulae or created from existing worksheets as in the following example.

Activity 10.1 Open the project called data4.opj from L:\win32apps\Origin 41\Samples
The Worksheet displayed should have three columns A(X), B(Y) and C(Z).

Activity 10.2 Highlight Column C(Z) and select Convert to Matrix from the Edit menu and choose Random XYZ.

Activity 10.3 The box shown in Figure 38 appears. Select the number of rows and columns, search radius and amount of smoothing required for the data.

The values selected will determine how fine/blocky your plot will be. From your xyz data, origin will interpolate values for each cell in the matrix - the more cells, the finer the plot but too many cells will take much longer to calculate and could be meaningless if there is not sufficient data. The search radius value is used to determine which of your xyz data points will be used to compute each cell value - this needs to be big enough to cover small gaps in the data but should not be so big that values at one end of the data set have an effect at the other end.

If you are not sure about values for your data set, try several different ones. For this example, accept the default values as above and press <OK>. The following matrix shown in Figure 39 appears:
Activity 10.4 The graph is now ready to be drawn. Open the Plot3D menu and click on the 3D-Color Map Surface option. The graph is then plotted as shown in Figure 40.

Activity 10.5 Now open the Plot Details dialog box by double clicking on one of the data grid points. Most of the options are self-explanatory so try and play around with them, especially experimenting with the Plot Type options at the bottom left of the dialog box.
Task 11     Quitting Origin

Objective     To leave Microcal Origin.

Instructions     You will use the Exit option from the File Menu.

Comments     You will be prompted to save any changes made to your document.

Activity 11.1 Select the Save Project option from the File menu to save any data files or graphs you have created. It is also possible to save just the graphs or worksheets or matrices that you are interested in for inclusion into another project. The project can now be reopened by selecting File > Open or by pressing the open project icon.

Activity 11.2 Select the Exit option from the File menu

Note     If you have not saved the file in the previous step, you are now given the opportunity to do so before exiting.
Further Information

On-line Help

Origin also incorporates an on-line help system which includes a search facility. You can access Help by choosing the Help menu.

Documentation

To find out more about Origin the following documents are available for reference, loan or purchase from the ISS Help Desk:

Microcal Origin User’s Manual
This contains a full description of Origin Facilities and self-teaching tutorials which is easy to follow and introduces the basics of Origin.

Microcal Origin 3D/Contour manual
This manual contains a series of tutorials that will teach you how to create 3D plots.

Microcal Origin Labtalk manual
Origin is based on a scripting language called Labtalk. It is a full-featured programming language. It allows users to write their own script using Labtalk and create their own Origin user interface.
Appendix 1  Types of Graph Available

2D Graphs

1  Scatter
   A Scatter Graph depicts each (x,y) data point as a symbol on the graph. Each set of data is represented by a new plot symbol.

2  Line
   A Line Graph depicts a data set as a curve on the graph.

3  Line + Symbol
   A Line+Symbol Graph plots the selected data as a line/symbol graph.

4  Area
   In an Area Graph the area between your graph and the x-axis is shaded in.

5  Bar
   A Bar Graph shows each (x,y) pair as a horizontal bar.

6  Column
   A Column Graph is similar to the Bar Graph except that each (x,y) pair is shown as a vertical bar.

7  Pie
   A Pie Chart displays variables as a portion of a circle.

8  Piece % Pie Chart
   A Piece % Pie Chart requires you to select two columns of Y data for plotting. The first column determines the size of each piece of the pie. Each piece is then broken into two segments. The values in the second Y column determine the size of the inner segment.

9  Stacked Bar
   In a Stacked Bar Graph each data set is placed end-to-end horizontally.

10  Stacked Column
    A Stacked Column is similar to the Stacked Bar Graph; however each data set is placed end-to-end vertically.

11  Floating Bar
    In a Floating Bar Graph, the bars do not necessarily start at the y axis.

12  Floating Column
    In a Floating Column Graph, the columns do not necessarily start at the x axis.

13  Hi-Lo-Close
To plot a Hi-Lo-Close chart requires you to select two or three columns of Y data. The first column contains the **Hi** value, the second contain the **Lo** value and the third contain the **Close** value.

### 14 Ternary Plots

A *Ternary* plot has a three-way axis system, suitable for displaying and comparing proportions between three variables.

### 15 Polar

A *Polar Graph* is ideal for graphing data with angular coordinates.

### 16 Vector Plots

A *Vector Plot* is a *Scatter Plot* showing size and direction of individual points.

### 17 Waterfall Plot

### 18 Statistical Charts

- Box Chart
- QC (X bar R) Chart
- Histogram
- Histogram + Probabilities

### 19 Analysis Charts

- Linear regression and Confidence Bands
- Baseline and Peak Analysis
- Zoom Details

### 3D Graphs

#### 1 3D Scatter

A *Scatter Graph* depicts each (x,y,z) data point as a symbol on the graph. Each set of data in the graph is represented by a new plot symbol.

#### 2 Trajectory Plots

A *Line Graph* depicts a data set as a curve on the graph.

#### 4 Multiple Y Plots

- Bar Plots
- Ribbon Plots
- Wall Plots
- Waterfall Plot

#### 5 Surface Plots

- Fill Surface Plots
- Wire Frame Plots
- Colour Map Surface Plots
- Solid Bars Plots
6 Contour Plots

- Colour Filled Contours Plots
- Contour Line Plots
- Grey Scale Maps
Appendix 2 Origin Examples